在新ipad發表後,不少App也隨之更新到最新版本
例如imovie,iphoto...等
不過,當您試著要安裝時,會跳出一個限制警告
螢幕快照 2012-03-11 下午8.30.58   

是的,您必須強制更新到ios5.1才行
對於jb者來說,就得抉擇要想要享受新版App,還是要享受全jb

現在,有種方式,可以騙過Apple這樣的識別
該原理說穿了
當iphone連線到Apple端,iphone上有個組態檔是在記錄目前版本為何
因此,只需要將該組態檔找出來修改成ios5.1就可以達到偽裝目的,方式如下:

注意:
此方法雖然可以改變iphone/ipad的ios版本欺騙遠端Server
 
但是不代表下載之後的App是可以執行的
因為,有些開發者會呼叫到真正ios5.1的函式庫
此時您沒有真正更新到ios5.1仍是無法執行的

1.
請確定iphone/ipad有安裝iFile這個App(可以到cydia下載)
打開iFile,找到如下路徑
/System/Library/CoreServices
IMG_2367   

2.
拉到最底下,找到SystemVersion.plist這個組態檔
點一下,請選擇純文字編輯器,打開如下
IMG_2368   

3.
請找到最後一行<string>5.0.1</string>
按左上角的編輯
IMG_2369  

把5.0.1改成5.1
按下右上角的"儲存"
最後Respring即可生效了
IMG_2370  

這時候,連線到App store去下載iMovie試試看
就可以不受限制的下載安裝囉

ps.
同樣方法也可以下載iphoto
但是很可惜,是不能用的
因為該App是有用到真正ios5.1的函式庫,因此無法執行
 

jimgau 發表在 痞客邦 PIXNET 留言(0) 人氣()